Font adjustments not working
  • jeffloganjefflogan
    March 2013
    I have been testing with adjusting fonts in the admin area. After many attempts and changes with valid fonts listed at Google Web Fonts I have not been successful in getting any new fonts to display.

    I check the sites code to make sure my changes have been applied, yes
    I checked different browsers, still no changes.

    Any ideas on what next?
  • mikemike
    March 2013
    You have to embed the CSS link from google. Follow googles example and past the CSS kit into your header.php file. That's all you are missing.

    It is listed as "Add this code to your website" like so:

    <link href='http://fonts.googleapis.com/css?family=Gabriela' rel='stylesheet' type='text/css'>
  • jimperatojimperato
    July 2013
    I am having a similar issue using typekits. I have installed this code into my header.php file.

    <script type="text/javascript" src="//use.typekit.net/pec2ktk.js"></script>
    <script type="text/javascript">try{Typekit.load();}catch(e){}</script>


    The odd this is that it worked perfectly for the main body font, but not for the main custom font. Any ideas?
  • mikemike
    July 2013
    Try editing the CSS to make sure that the font is being used. Add !important if necessary:

    ul.filter-children li a, #respond input#submit, .sf-menu, .flex-caption, footer #copyright ul, .rock-button, h1, h2, h3, h4, h5, h6, .phone-widget span, .e-mail-widget span, .mobile-widget span, body #main ul.menu-items .grid2column, .pagination a, body #main a.progression-grey
    {font-family:'Droid Serif', serif !important; }


    If that still doesn't help, you will need to visit type-kit specific forums as this will be a type-kit issue.